Degraded performance with our main website - crossref.org
Incident Report for Crossref
Resolved
This incident has been resolved.
Posted May 07, 2022 - 03:11 UTC
Investigating
Hetzner, our host for crossref.org, is currently experiencing a distributed denial-of-service (DDoS) attack that is causing performance problems with our main web site. We’ll be following Hetzner’s status page for the latest: https://status.hetzner.com/incident/ea9ed47d-ecfa-49bd-a961-fdfbdaf026e0. Note: this is note impacting deposits, our API, or any other Crossref services.
Posted May 06, 2022 - 22:17 UTC
This incident affected: Sites (Crossref website).