Similarity Check subscribers: some Similarity Reports not generating and stuck at pending in iThenticate tool
Incident Report for Crossref
Resolved
This incident has been resolved.
Posted May 25, 2021 - 14:07 UTC
Update
Turnitin has completed reprocessing all pending submissions affected by this incident. If you are still finding submissions stuck in the pending stage, please let us know via support@crossref.org.
Posted May 21, 2021 - 15:55 UTC
Update
iThenticate is now running a script to reprocess the submissions that were affected during this incident. Submissions should now gradually start to produce reports. It looks like it will take 4-6 days to complete reprocessing all submissions and iThenticate will be keeping us updated.
Posted May 19, 2021 - 15:55 UTC
Update
We have confirmed with some members and iThenticate now seems fully operational. However, the pending submissions are still being processed and will take a little time to work through. We will update here when we know more about that timeline. Crossref is meeting with Turnitin today to discuss how this might have been avoided, how our SLA with them was affected, and how to improve incident response communication in future.
Posted May 18, 2021 - 10:53 UTC
Monitoring
Turnitin believes this is fixed so we are confirming with some members. Let us know via @CrossrefSupport or support@crossref.org if you are still experiencing issues with iThenticate.
Posted May 18, 2021 - 07:58 UTC
Update
Turnitin believes it has located the root cause of this issue and is working hard to resolve it as its top priority. They will be updating the incident at https://turnitin.statuspage.io/incidents/m9bq6spq9f1z as they go. We are sorry for the interruption this is causing Crossref members using Similarity Check/iThenticate.
Posted May 17, 2021 - 16:01 UTC
Identified
Similarity Check subscribers are reporting issues with reports not generating and showing as pending in the iThenticate tool. The team at Turnitin is aware and has identified that this is affecting submissions with titles that contain non-English characters. They are working on the problem - take a look at their status page at https://turnitin.statuspage.io/ for the latest.
Posted May 14, 2021 - 16:24 UTC
This incident affected: External dependencies (Similarity Check via iThenticate from Turnitin - status found at https://turnitin.statuspage.io/).