Submission processing delays
Incident Report for Crossref
Resolved
This incident has been resolved. - KL
Posted Jun 28, 2024 - 20:36 UTC
Identified
We're still seeing submission processing delays in our admin tool, so we're taking extra steps to restore the system. -IF
Posted Jun 28, 2024 - 16:02 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 28, 2024 - 15:16 UTC
Investigating
Submission processing has been delayed in our admin tool - doi.crossref.org - for the last 30 minutes. We are investigating. We're storing all submissions and processing those submissions as quickly as we can. -IF
Posted Jun 28, 2024 - 14:52 UTC
This incident affected: Content Registration (Admin tool).