Similarity Check service - incorrect Similarity Score displaying in the document viewer for some subscribers
Incident Report for Crossref
Resolved
This problem has now been resolved, and the correct Similarity Score is now displaying within the document viewer.
Posted Apr 30, 2021 - 18:26 UTC
Investigating
If the file being checked is in a folder which has exclusions applied, the document viewer is generating the score as if there were no exclusions. The correct score (with the exclusions in place) is being shown in the PDF and through the API.

As a workaround, subscribers can re-apply the exclusions to the document viewer.

Turnitin are aware of the issue and are working to solve the problem.
Posted Apr 30, 2021 - 10:49 UTC
This incident affected: External dependencies (Similarity Check via iThenticate from Turnitin - status found at https://turnitin.statuspage.io/).